re = /,(?![^()]*\))/m
str = 'K.VisueelNr,IFNULL(P.Partijnaam, \'Leeg gemeld\')'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result