use strict;
my $str = 'K.VisueelNr,IFNULL(P.Partijnaam, \'Leeg gemeld\')';
my $regex = qr/,(?![^()]*\))/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";