#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)START(.*?)END"
Local $sString = "START This is the test which I want to extract and a use for my own purpose END adsdfs" & @CRLF & _
"sdfsdfsd" & @CRLF & _
"sdfsdfds sdfsd fd START This is the test which I want to extract and a use for my own purpose END sdfsdfsdf sdfsdf START This is the test which I want to extract and a use for my own purpose END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")