$re = '/START(.*?)END/m';
$str = 'START This is the test which I want to extract and a use for my own purpose END adsdfs
sdfsdfsd
sdfsdfds sdfsd fd START This is the test which I want to extract and a use for my own purpose END sdfsdfsdf sdfsdf START This is the test which I want to extract and a use for my own purpose END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);