import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "START(.*?)END";
final String string = "START This is the test which I want to extract and a use for my own purpose END adsdfs\n"
+ "sdfsdfsd\n"
+ "sdfsdfds sdfsd fd START This is the test which I want to extract and a use for my own purpose END sdfsdfsdf sdfsdf START This is the test which I want to extract and a use for my own purpose END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}