// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)START(.*?)END").unwrap();
let string = "START This is the test which I want to extract and a use for my own purpose END adsdfs
sdfsdfsd
sdfsdfds sdfsd fd START This is the test which I want to extract and a use for my own purpose END sdfsdfsdf sdfsdf START This is the test which I want to extract and a use for my own purpose END";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}