import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "my_function\\([a-zA-Z0-9,-_'\"\\s]*?nil[a-zA-Z0-9,-_'\"\\s]*?\\)";
final String string = "\n\n"
+ "var = ( my_function('test', 'test2') + nil )\n\n"
+ "my_function('test', 'test2') + nil\n\n"
+ "my_function('test', 'test2')\n\n"
+ " my_function(\"t-e-s-t_5\", nil)\n\n"
+ "my_function('test3', 'test4')\n\n"
+ "my_function(nil, 'test5') # other text\n\n\n"
+ " var = ( my_function('test5', nil) + 1 )\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}