import Foundation
let pattern = #"my_function\([a-zA-Z0-9,-_'"\s]*?nil[a-zA-Z0-9,-_'"\s]*?\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
var = ( my_function('test', 'test2') + nil )
my_function('test', 'test2') + nil
my_function('test', 'test2')
my_function("t-e-s-t_5", nil)
my_function('test3', 'test4')
my_function(nil, 'test5') # other text
var = ( my_function('test5', nil) + 1 )
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)