$re = '/my_function\([a-zA-Z0-9,-_\'"\s]*?nil[a-zA-Z0-9,-_\'"\s]*?\)/';
$str = '
var = ( my_function(\'test\', \'test2\') + nil )
my_function(\'test\', \'test2\') + nil
my_function(\'test\', \'test2\')
my_function("t-e-s-t_5", nil)
my_function(\'test3\', \'test4\')
my_function(nil, \'test5\') # other text
var = ( my_function(\'test5\', nil) + 1 )
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);