// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"my_function\([a-zA-Z0-9,-_'"\s]*?nil[a-zA-Z0-9,-_'"\s]*?\)"#).unwrap();
let string = "
var = ( my_function('test', 'test2') + nil )
my_function('test', 'test2') + nil
my_function('test', 'test2')
my_function(\"t-e-s-t_5\", nil)
my_function('test3', 'test4')
my_function(nil, 'test5') # other text
var = ( my_function('test5', nil) + 1 )
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}