#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^a-z]*[a-z][^a-z]*){5}$"
Local $sString = "abcde.jav" & @CRLF & _
"a156e.exc" & @CRLF & _
"test.c" & @CRLF & _
"prog1.c" & @CRLF & _
"qwerty" & @CRLF & _
"r.c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")