$re = '/^(?:[^a-z]*[a-z][^a-z]*){5}$/m';
$str = 'abcde.jav
a156e.exc
test.c
prog1.c
qwerty
r.c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);