package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^a-z]*[a-z][^a-z]*){5}$`)
var str = `abcde.jav
a156e.exc
test.c
prog1.c
qwerty
r.c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}