import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^a-z]*[a-z][^a-z]*){5}$";
final String string = "abcde.jav\n"
+ "a156e.exc\n"
+ "test.c\n"
+ "prog1.c\n"
+ "qwerty\n"
+ "r.c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}