using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![:/])(/.*$)";
string substitution = @"lol";
string input = @"http://google.com/whatever/who/jx.html";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}