const regex = new RegExp('(?<![:/])(/.*$)', '')
const str = `http://google.com/whatever/who/jx.html`;
const subst = `lol`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);