use strict;
my $str = 'http://google.com/whatever/who/jx.html';
my $regex = qr/(?<![:/])(/.*$)/p;
my $subst = 'lol';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";