re = /(?<![:\/])(\/.*$)/
str = 'http://google.com/whatever/who/jx.html'
subst = 'lol'
result = str.sub(re, subst)
# Print the result of the substitution
puts result