using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/api\/v1\/(?!users\/invitation_register\b).*";
string input = @"/api/v1/users/invitation_register
/api/v1/users
/api/v1/other_stuff
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}