re = /^\/api\/v1\/(?!users\/invitation_register\b).*/m
str = '/api/v1/users/invitation_register
/api/v1/users
/api/v1/other_stuff
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end