$re = '/^\/api\/v1\/(?!users\/invitation_register\b).*/m';
$str = '/api/v1/users/invitation_register
/api/v1/users
/api/v1/other_stuff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);