const regex = /^\/api\/v1\/(?!users\/invitation_register\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/api\\\/v1\\\/(?!users\\\/invitation_register\\b).*', 'gm')
const str = `/api/v1/users/invitation_register
/api/v1/users
/api/v1/other_stuff
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}