using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\b(?=\s)(?=(?:[^>=]|='[^']*'|=""[^""]*""|=[^'""][^\s>]*)*?\ssrc=['""]([^""]*)['""]?)(?:[^>=]|='[^']*'|=""[^""]*""|=[^'""\s]*)*""\s?\/?> ";
string input = @"<img onmouseover=' if ( 6 > 3 { funSwap("" src=""NotTheDroidYourLookingFor.jpg"", 6 > 3 ) } ; ' src=""http://website/ThisIsTheDroidYourLookingFor.jpeg"" onload=""img_onload(this);"" onerror=""img_onerror(this);"" data-pid=""jihgfedcba"" data-imagesize=""ppew"" />
some text
<img src=""http://website/someurl.jpeg"" onload=""img_onload(this);"" />
more text
<img src=""https://en.wikipedia.org/wiki/File:BH_LMC.png""/>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}