import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\b(?=\\s)(?=(?:[^>=]|='[^']*'|=\"[^\"]*\"|=[^'\"][^\\s>]*)*?\\ssrc=['\"]([^\"]*)['\"]?)(?:[^>=]|='[^']*'|=\"[^\"]*\"|=[^'\"\\s]*)*\"\\s?\\/?> ";
final String string = "<img onmouseover=' if ( 6 > 3 { funSwap(\" src=\"NotTheDroidYourLookingFor.jpg\", 6 > 3 ) } ; ' src=\"http://website/ThisIsTheDroidYourLookingFor.jpeg\" onload=\"img_onload(this);\" onerror=\"img_onerror(this);\" data-pid=\"jihgfedcba\" data-imagesize=\"ppew\" />\n"
+ "some text\n\n"
+ "<img src=\"http://website/someurl.jpeg\" onload=\"img_onload(this);\" />\n"
+ "more text\n"
+ "<img src=\"https://en.wikipedia.org/wiki/File:BH_LMC.png\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}