const regex = new RegExp('<img\\b(?=\\s)(?=(?:[^>=]|=\\'[^\\']*\\'|="[^"]*"|=[^\\'"][^\\s>]*)*?\\ssrc=[\\'"]([^"]*)[\\'"]?)(?:[^>=]|=\\'[^\\']*\\'|="[^"]*"|=[^\\'"\\s]*)*"\\s?\\/?> ', 'gmi')
const str = `<img onmouseover=' if ( 6 > 3 { funSwap(" src="NotTheDroidYourLookingFor.jpg", 6 > 3 ) } ; ' src="http://website/ThisIsTheDroidYourLookingFor.jpeg" onload="img_onload(this);" onerror="img_onerror(this);" data-pid="jihgfedcba" data-imagesize="ppew" />
some text
<img src="http://website/someurl.jpeg" onload="img_onload(this);" />
more text
<img src="https://en.wikipedia.org/wiki/File:BH_LMC.png"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}