#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)Client logging in as (?<user_failed_login>[^ ]*).*failed"
Local $sString = " 017/09/25 10:58:57 Client logging in as robertE on DB1..." & @CRLF & _
" Connect to Oracle failed: " & @CRLF & _
" ORA-01017: invalid username/password; logon denied" & @CRLF & _
" ERROR:User login failed!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")