const regex = /(?ms)Client logging in as (?<user_failed_login>[^ ]*).*failed/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)Client logging in as (?<user_failed_login>[^ ]*).*failed', 'g')
const str = ` 017/09/25 10:58:57 Client logging in as robertE on DB1...
Connect to Oracle failed:
ORA-01017: invalid username/password; logon denied
ERROR:User login failed!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}