package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)Client logging in as (?<user_failed_login>[^ ]*).*failed`)
var str = ` 017/09/25 10:58:57 Client logging in as robertE on DB1...
Connect to Oracle failed:
ORA-01017: invalid username/password; logon denied
ERROR:User login failed!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}