import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)Client logging in as (?<user_failed_login>[^ ]*).*failed";
final String string = " 017/09/25 10:58:57 Client logging in as robertE on DB1...\n"
+ " Connect to Oracle failed: \n"
+ " ORA-01017: invalid username/password; logon denied\n"
+ " ERROR:User login failed!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}