#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):([0-9]{2}[A-Z]){1}(::|:)((.*\r\n){1,4}|.*)"
Local $sString = ":16R:FIN" & @CRLF & _
":35B:ISIN CH0117044708" & @CRLF & _
"ANTEILE -DT USD- SWISSCANTO (CH)" & @CRLF & _
"INDEX FUND V - SWISSCANTO (CH)" & @CRLF & _
"INDEX EQUITY FUND USA" & @CRLF & _
":16R:FIA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")