package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):([0-9]{2}[A-Z]){1}(::|:)((.*\r\n){1,4}|.*)`)
var str = `:16R:FIN
:35B:ISIN CH0117044708
ANTEILE -DT USD- SWISSCANTO (CH)
INDEX FUND V - SWISSCANTO (CH)
INDEX EQUITY FUND USA
:16R:FIA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}