re = /:([0-9]{2}[A-Z]){1}(::|:)((.*\r\n){1,4}|.*)/m
str = ':16R:FIN
:35B:ISIN CH0117044708
ANTEILE -DT USD- SWISSCANTO (CH)
INDEX FUND V - SWISSCANTO (CH)
INDEX EQUITY FUND USA
:16R:FIA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end