import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":([0-9]{2}[A-Z]){1}(::|:)((.*\\r\\n){1,4}|.*)";
final String string = ":16R:FIN\n"
+ ":35B:ISIN CH0117044708\n"
+ "ANTEILE -DT USD- SWISSCANTO (CH)\n"
+ "INDEX FUND V - SWISSCANTO (CH)\n"
+ "INDEX EQUITY FUND USA\n"
+ ":16R:FIA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}