import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!^[^0-9]+$)[^0-9_].{5,17}(.)\\1$";
final String string = "9fda32aa\n"
+ "_54lasdbb\n"
+ "fdfjdkalg\n"
+ "dfdkslaa\n"
+ "ds4fdklall\n"
+ "dfd3235\n"
+ "dsd__3*4329_+21fdjfdkjalgkjdkajgkdd\n"
+ "a__++__++321fdall\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}