package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@media[^\{]+\{([^\{\}]*\{[^\}\{]*\})+[^\}]+\}`)
var str = `.visible-desktop {
display: inherit !important;
}
#intro .container {
margin:0 auto;
display:table;
}
@media (max-width: 480px) {
#intro .download-php { margin: 0; }
}
@media (min-width: 768px) and (max-width: 979px) {
.hidden-desktop {
display: inherit !important;
}
.visible-desktop {
display: none !important ;
}
.visible-tablet {
display: inherit !important;
}
.hidden-tablet {
display: none !important;
}
}
body, input, textarea {
font-family: "Fira Sans", "Source Sans Pro", Helvetica, Arial, sans-serif;
font-weight: 400;
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}