// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"@media[^\{]+\{([^\{\}]*\{[^\}\{]*\})+[^\}]+\}").unwrap();
let string = ".visible-desktop {
display: inherit !important;
}
#intro .container {
margin:0 auto;
display:table;
}
@media (max-width: 480px) {
#intro .download-php { margin: 0; }
}
@media (min-width: 768px) and (max-width: 979px) {
.hidden-desktop {
display: inherit !important;
}
.visible-desktop {
display: none !important ;
}
.visible-tablet {
display: inherit !important;
}
.hidden-tablet {
display: none !important;
}
}
body, input, textarea {
font-family: \"Fira Sans\", \"Source Sans Pro\", Helvetica, Arial, sans-serif;
font-weight: 400;
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}