import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@media[^\\{]+\\{([^\\{\\}]*\\{[^\\}\\{]*\\})+[^\\}]+\\}";
final String string = ".visible-desktop {\n"
+ " display: inherit !important;\n"
+ "}\n\n"
+ "#intro .container {\n"
+ " margin:0 auto;\n"
+ " display:table;\n"
+ "}\n\n"
+ "@media (max-width: 480px) {\n"
+ " #intro .download-php { margin: 0; }\n"
+ "}\n\n"
+ "@media (min-width: 768px) and (max-width: 979px) {\n"
+ " .hidden-desktop {\n"
+ " display: inherit !important;\n"
+ " }\n"
+ " .visible-desktop {\n"
+ " display: none !important ;\n"
+ " }\n"
+ " .visible-tablet {\n"
+ " display: inherit !important;\n"
+ " }\n"
+ " .hidden-tablet {\n"
+ " display: none !important;\n"
+ " }\n\n"
+ "}\n\n"
+ "body, input, textarea {\n"
+ " font-family: \"Fira Sans\", \"Source Sans Pro\", Helvetica, Arial, sans-serif;\n"
+ " font-weight: 400;\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}