use strict;
my $str = 'http://www.foo.com/mn
http://www.foodev.com/mn
http://www.foo.com/MN
http://www.foodev.com/MN
http://www.foo.com/la/mn
http://www.foo.com/la/di/da/mn
http://www.foodev.com/la/mn
http://www.foodev.com/la/di/da/mn';
my $regex = qr/\.com\/mn/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}