$re = '/\.com\/mn/mi';
$str = 'http://www.foo.com/mn
http://www.foodev.com/mn
http://www.foo.com/MN
http://www.foodev.com/MN
http://www.foo.com/la/mn
http://www.foo.com/la/di/da/mn
http://www.foodev.com/la/mn
http://www.foodev.com/la/di/da/mn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);