import Foundation
let pattern = #"\.com\/mn"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://www.foo.com/mn
http://www.foodev.com/mn
http://www.foo.com/MN
http://www.foodev.com/MN
http://www.foo.com/la/mn
http://www.foo.com/la/di/da/mn
http://www.foodev.com/la/mn
http://www.foodev.com/la/di/da/mn
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)