#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)urn:mystuff:v1:(ABC\.([^A]\S*|A([^c.]\S*)?|Ac([^m.]\S*)?|Acm([^e.]\S*)?)\.\S+\.a\d+\.v\d+|ABC\.Acme\.\S+\.a\d+\.\d+\.\d+)$"
Local $sString = "urn:mystuff:v1:ABC.Test.MyData.a1.v1" & @CRLF & _
"urn:mystuff:v1:ABC.Acme.MyData.a1.0.1" & @CRLF & _
"" & @CRLF & _
"urn:mystuff:v1:ABC.ARGTE.MyData.a1.v1" & @CRLF & _
"" & @CRLF & _
"urn:mystuff:v1:ABC.A.MyData.a1.v1" & @CRLF & _
"urn:mystuff:v1:ABC.Ac.MyData.a1.v1" & @CRLF & _
"urn:mystuff:v1:ABC.Acm.MyData.a1.v1" & @CRLF & _
"urn:mystuff:v1:ABC.Acmy.MyData.a1.v1" & @CRLF & _
"urn:mystuff:v1:ABC.Acme.MyData.a1.v1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"But I would like the following to fail" & @CRLF & _
"" & @CRLF & _
"urn:mystuff:v1:ABC.Acme.MyData.a1.v1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")