using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"urn:mystuff:v1:(ABC\.([^A]\S*|A([^c.]\S*)?|Ac([^m.]\S*)?|Acm([^e.]\S*)?)\.\S+\.a\d+\.v\d+|ABC\.Acme\.\S+\.a\d+\.\d+\.\d+)$";
string input = @"urn:mystuff:v1:ABC.Test.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.0.1
urn:mystuff:v1:ABC.ARGTE.MyData.a1.v1
urn:mystuff:v1:ABC.A.MyData.a1.v1
urn:mystuff:v1:ABC.Ac.MyData.a1.v1
urn:mystuff:v1:ABC.Acm.MyData.a1.v1
urn:mystuff:v1:ABC.Acmy.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.v1
But I would like the following to fail
urn:mystuff:v1:ABC.Acme.MyData.a1.v1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}