import Foundation
let pattern = #"urn:mystuff:v1:(ABC\.([^A]\S*|A([^c.]\S*)?|Ac([^m.]\S*)?|Acm([^e.]\S*)?)\.\S+\.a\d+\.v\d+|ABC\.Acme\.\S+\.a\d+\.\d+\.\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
urn:mystuff:v1:ABC.Test.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.0.1
urn:mystuff:v1:ABC.ARGTE.MyData.a1.v1
urn:mystuff:v1:ABC.A.MyData.a1.v1
urn:mystuff:v1:ABC.Ac.MyData.a1.v1
urn:mystuff:v1:ABC.Acm.MyData.a1.v1
urn:mystuff:v1:ABC.Acmy.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.v1
But I would like the following to fail
urn:mystuff:v1:ABC.Acme.MyData.a1.v1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)