use strict;
my $str = 'urn:mystuff:v1:ABC.Test.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.0.1
urn:mystuff:v1:ABC.ARGTE.MyData.a1.v1
urn:mystuff:v1:ABC.A.MyData.a1.v1
urn:mystuff:v1:ABC.Ac.MyData.a1.v1
urn:mystuff:v1:ABC.Acm.MyData.a1.v1
urn:mystuff:v1:ABC.Acmy.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.v1
But I would like the following to fail
urn:mystuff:v1:ABC.Acme.MyData.a1.v1';
my $regex = qr/urn:mystuff:v1:(ABC\.([^A]\S*|A([^c.]\S*)?|Ac([^m.]\S*)?|Acm([^e.]\S*)?)\.\S+\.a\d+\.v\d+|ABC\.Acme\.\S+\.a\d+\.\d+\.\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}