$re = '/med venlig hilsen| hilsn?e?r?n?|groten|met (vriendelijke|hartelijke) groten| groeten| groet|
terveisin| h[ä|a]lsninga?r?| kveðja/i';
$str = ' hilser';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);