import re
regex = re.compile((r"med venlig hilsen| hilsn?e?r?n?|groten|met (vriendelijke|hartelijke) groten| groeten| groet| \n"
r"terveisin| h[ä|a]lsninga?r?| kveðja"), flags=re.IGNORECASE)
test_str = " hilser"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")