// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)med venlig hilsen| hilsn?e?r?n?|groten|met (vriendelijke|hartelijke) groten| groeten| groet|
terveisin| h[ä|a]lsninga?r?| kveðja").unwrap();
let string = " hilser";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}