# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:<span[^>]*?>)(?!<a)(.*?)(?:<\\/span>)/\1/g;t' <<< "<span style=\"font-family: inherit; font-weight: inherit; line-height: 1.3;\"> <b>including their</b> </span>
<span style=\"font-family: inherit; font-weight: inherit; line-height: 1.3;\">StackOverflow</span>
<span class=\"MainLink\" style=\"font-weight: bold\"><a href=\"https://website.com/\" style=\"color: #2f82de; text-decoration: none\">link name</a></span>
<a href=\"http://www.google.com\"><span>testing</span></a>"