import Foundation
let pattern = #"(?:<span[^>]*?>)(?!<a)(.*?)(?:<\/span>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<span style="font-family: inherit; font-weight: inherit; line-height: 1.3;"> <b>including their</b> </span>
<span style="font-family: inherit; font-weight: inherit; line-height: 1.3;">StackOverflow</span>
<span class="MainLink" style="font-weight: bold"><a href="https://website.com/" style="color: #2f82de; text-decoration: none">link name</a></span>
<a href="http://www.google.com"><span>testing</span></a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)