# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<span[^>]*?>)(?!<a)(.*?)(?:<\/span>)"
test_str = ("<span style=\"font-family: inherit; font-weight: inherit; line-height: 1.3;\"> <b>including their</b> </span>\n\n"
"<span style=\"font-family: inherit; font-weight: inherit; line-height: 1.3;\">StackOverflow</span>\n\n"
"<span class=\"MainLink\" style=\"font-weight: bold\"><a href=\"https://website.com/\" style=\"color: #2f82de; text-decoration: none\">link name</a></span>\n\n"
"<a href=\"http://www.google.com\"><span>testing</span></a>")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.